Alpha version available for download

Discussion related to the exprimental TYT MD-9600 / Retevis RT-90 version
VK3KYY
Posts: 4537
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Alpha version available for download

Post by VK3KYY » Mon Apr 11, 2022 11:02 pm

That error message is created for 2 possible reasons, but STM don't seem to publish what the error codes mean

I'll need to make a updated version of the loader that shows which of the 2 possible functions (commands) is giving the error

Potentially, its the secret / nonstandard command that tells the bootloader to allow the radio to be upated.

If thats a case, the only way of knowing what command your radio requires is for you to run WireShark and log the USB traffic when the official installer loads the firemware; but thats quite difficult to do.



Just a thought , but are you using the official cable etc

VK3KYY
Posts: 4537
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Alpha version available for download

Post by VK3KYY » Mon Apr 11, 2022 11:36 pm

Try this version

http://opengd77.com/downloads/MD9600/Fi ... 041201.zip

It won't fix the problem, but it should indicate which command is failing

TA2KW
Posts: 13
Joined: Sat Apr 09, 2022 7:32 pm
Location: KN40PP
Contact:

Re: Alpha version available for download

Post by TA2KW » Tue Apr 12, 2022 8:13 am

VK3KYY wrote:
Mon Apr 11, 2022 11:36 pm
Try this version

http://opengd77.com/downloads/MD9600/Fi ... 041201.zip

It won't fix the problem, but it should indicate which command is failing

I tried with the new loader you gave, the result is still frustration :(

Image

I believe I am the unluckiest person in this world :(

G4EML
Posts: 436
Joined: Sat Nov 16, 2019 10:01 am

Re: Alpha version available for download

Post by G4EML » Tue Apr 12, 2022 9:24 am

Just an observation, it might not be important but the screen capture shows you are running from drive E: . If that is an external drive it could be causing problems with timing especially if it is a slow connection.

Have you tried copying the program and firmware to drive C: and running from there?

Colin.

TA2KW
Posts: 13
Joined: Sat Apr 09, 2022 7:32 pm
Location: KN40PP
Contact:

Re: Alpha version available for download

Post by TA2KW » Tue Apr 12, 2022 10:05 am

G4EML wrote:
Tue Apr 12, 2022 9:24 am
Just an observation, it might not be important but the screen capture shows you are running from drive E: . If that is an external drive it could be causing problems with timing especially if it is a slow connection.

Have you tried copying the program and firmware to drive C: and running from there?

Colin.
Image

Yes, I tried what you said. the result is disappointing again :(
C drive M.2 SSD
D drive M.2 SSD
E drive SSD

i don't have hdd on my pc

thank you for your support.

TA2KW
Posts: 13
Joined: Sat Apr 09, 2022 7:32 pm
Location: KN40PP
Contact:

Re: Alpha version available for download

Post by TA2KW » Tue Apr 12, 2022 10:46 am

computers and operating systems where I'm trying to install the alpha version

1) desktop pc win10
2) laptop pc win7
3) laptop pc win11

Installation failed on these 3 computers.

I gave up :(

VK3KYY
Posts: 4537
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Alpha version available for download

Post by VK3KYY » Tue Apr 12, 2022 10:37 pm

Can you check what driver version is installed

I'm using driver version 3.0.4.0 (5/07/2012)

Which seems to be the version Windows automatically installed.

Also what USB VID/PID "Hardware Ids" does your radio appear as when in upload mode.



BTW.

The problem is not occurring when sending the 'custom' unlocking command, its occuring when the loader send the "Select Current Configuration" command.

Unfortunately, I searched for "STDFU_SelectCurrentConfiguration" to find out what this does, but there does not appear to be any usefull information about this command anywhere on the internet.

VK3KYY
Posts: 4537
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Alpha version available for download

Post by VK3KYY » Wed Apr 13, 2022 3:49 am

Language translation update for Italian and Gernam users

See

downloads/MD9600/Firmware/819b259a37c4a ... 1dc3be1e5d

No new features or bug fixes are in this version

TA2KW
Posts: 13
Joined: Sat Apr 09, 2022 7:32 pm
Location: KN40PP
Contact:

Re: Alpha version available for download

Post by TA2KW » Wed Apr 13, 2022 9:47 am

VK3KYY wrote:
Tue Apr 12, 2022 10:37 pm
Can you check what driver version is installed

I'm using driver version 3.0.4.0 (5/07/2012)

Which seems to be the version Windows automatically installed.

Also what USB VID/PID "Hardware Ids" does your radio appear as when in upload mode.



BTW.

The problem is not occurring when sending the 'custom' unlocking command, its occuring when the loader send the "Select Current Configuration" command.

Unfortunately, I searched for "STDFU_SelectCurrentConfiguration" to find out what this does, but there does not appear to be any usefull information about this command anywhere on the internet.
these are the dfu drivers installed.

Image

Am I the only one in the world having this problem? I am very curious :)

TA2KW
Posts: 13
Joined: Sat Apr 09, 2022 7:32 pm
Location: KN40PP
Contact:

Re: Alpha version available for download

Post by TA2KW » Wed Apr 13, 2022 10:07 am

usb info in setup mode

Image

Post Reply