DM-1801 charger schematic avaialble?

Anything specifically related to the DM-1801 version of the firmware
Post Reply
n1kk
Posts: 5
Joined: Sun Mar 15, 2020 2:37 am

DM-1801 charger schematic avaialble?

Post by n1kk » Sun Jul 25, 2021 4:26 pm

My charger from the day one out of the box, while charging never switches from RED to GREEN indicating fully charge.
I measure around 8.2--8.3 volts across the connection points of the charger and about
the same across a battery after charging for a few hours.

I would be interesting in seeing the schematic of the charger to determine what causes
the RED to switch to GREEN.

Thanks
Ken

User avatar
F1RMB
Posts: 1201
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: DM-1801 charger schematic avaialble?

Post by F1RMB » Sun Jul 25, 2021 4:54 pm

Hi,

Don't bother with that crappy charger, check this out viewtopic.php?f=8&t=564


Cheers.
---
Daniel
73 de Daniel.

G4EML
Posts: 285
Joined: Sat Nov 16, 2019 10:01 am

Re: DM-1801 charger schematic avaialble?

Post by G4EML » Mon Jul 26, 2021 10:29 am

Ken,

‘A few Hours’ is probably not enough. The standard charger is very slow. It can take 8 hours to fully charge. You may need to leave it overnight.

Colin G4EML.

User avatar
F1RMB
Posts: 1201
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: DM-1801 charger schematic avaialble?

Post by F1RMB » Mon Jul 26, 2021 10:44 am

Hi,

I had one of my charger with the same symptom. Since I replaced the board, everything's working as expected.


Cheers.
---
Daniel
73 de Daniel.

n1kk
Posts: 5
Joined: Sun Mar 15, 2020 2:37 am

Re: DM-1801 charger schematic avaialble?

Post by n1kk » Fri Jul 30, 2021 6:21 pm

I ordered a TP5100 charger from ebay. Hopefully I'll have it next week. Shipped from
U.S.

I have stock board removed. Until the TP5100 arrives I am using my iMax B6 charger with leads
clipped onto the charging post.

Ken

n1kk
Posts: 5
Joined: Sun Mar 15, 2020 2:37 am

Re: DM-1801 charger schematic avaialble?

Post by n1kk » Thu Sep 02, 2021 3:50 pm

the swap out took about 20 mins. The TP5100 is working perfectly.
Shuts off at the right voltage.

Ken

Post Reply