Win 11 No comm port available....

Post Reply
k8md
Posts: 7
Joined: Sat Dec 14, 2019 9:05 am

Win 11 No comm port available....

Post by k8md » Sun May 01, 2022 9:45 pm

Not sure what was / is happening. I hope someone finds this information useful. I am using Win11. I was able to upgrade the firmware in both my GD77's with the February firmware with no problems. I am having intermittent problems programming the radios with CPS.

When the GD77 is powered and connected to the computer, it's showing up as a "OpenGD77" on COM3. When I try to read or write with CPS, CPS gives me an error: Comm Port Not Available. Windows believes the driver is working correctly. The driver appeared to install when I installed CPS. To make sure, I installed the driver again from the opengd77 website. It continues to show up as COM3.

I started typing this message and attempted to read the codeplug again so I could get the exact wording of the error message, and programming suddenly started working. I could read and write the codeplug. I plugged in my second GD77 and got the same error: "Comm Port Not Available" even though the OpenGD77 was again on COM3. I let the radio sit for a while and kept hitting the read button. Eventually the time period elapsed and it started reading / writing that radio just fine. I restarted the CPS and it's still behaving the same way.

After the time has elapsed and it starts working, it seems to keep working just fine with that radio. Multiple reads and writes of the radio without any problems. If I disconnect the cable and power cycle the radio then I'm back to square one and waiting out the time period until it starts working.

I just used a stopwatch and timed it. It takes 5:00 minutes after windows makes the beep indicating the hardware was connected before I was able to successfully read / write the radio. Hitting the read / write buttons and getting the error does not seem to have any effect on the time.

VK3KYY
Posts: 4453
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Win 11 No comm port available....

Post by VK3KYY » Mon May 02, 2022 10:42 pm

Several people have reported a problem with Windows 11, but most people seem to have worked around it somehow

Try using Google to search this site for Windows 11 questions and you may be able to find out what people did to fix their individial problems.

Also, hundreds of people have used the CPS with Windows 11 with no problems at all.
The problem seems to occur on specific PC's using Windows 11, so the problem appears to be a combination of Windows 11 and the PC hardware.
This points to a problem with Windows 11 its self, and Windows 10 always works just fine

Post Reply