1750Hz Tone not exact? FM-Repeater problem

DO4CZ
Posts: 57
Joined: Sat Nov 16, 2019 8:55 am
Location: near Rostock, Germany

Re: 1750Hz Tone not exact? FM-Repeater problem

Post by DO4CZ » Sun Jul 19, 2020 9:51 am

Roger, i tested today's firmware (1750Hz fix).
I was able to open a relay 20 km away with 1750 Hz tone without any problems.

Thanks for the fix!
73, Joerg DO4CZ - 2x GD-77 ( 1x as a hotspot and 1x for normal operation )

VK3KYY
Posts: 3203
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: 1750Hz Tone not exact? FM-Repeater problem

Post by VK3KYY » Sun Jul 19, 2020 10:41 am

DO4CZ wrote:
Sun Jul 19, 2020 9:51 am
Roger, i tested today's firmware (1750Hz fix).
I was able to open a relay 20 km away with 1750 Hz tone without any problems.

Thanks for the fix!
OK.

FYI. I hope DG3GSP will test it tomorrow using a deviation meter, and perhaps confirm if the OpenGD77 firmware now has exactly the same deviation level as the official firmware.

Even if the deviation is not identical to the official firmware, I will still retain this fix, as the deviation level is definitely better now.

DG3GSP
Posts: 97
Joined: Sun Nov 17, 2019 9:30 am
Location: Southern Germany

Re: 1750Hz Tone not exact? FM-Repeater problem

Post by DG3GSP » Sun Jul 19, 2020 4:38 pm

Of course I will (as promised) measure the deviation tomorrow at the lab..

At a first quick check (by ear ;) )the calltone & the DTMF seems to be ok now.
73, Peter DG3GSP

LY1RF
Posts: 30
Joined: Sun Mar 01, 2020 12:05 pm

Re: 1750Hz Tone not exact? FM-Repeater problem

Post by LY1RF » Sun Jul 19, 2020 8:18 pm

Now I can open repeater with 1750 tone 80 km away !

DG3GSP
Posts: 97
Joined: Sun Nov 17, 2019 9:30 am
Location: Southern Germany

Re: 1750Hz Tone not exact? FM-Repeater problem

Post by DG3GSP » Mon Jul 20, 2020 11:42 am

did the deviation measurement today (with latest development release):

@12,5kHz bandwith(dev. should be 2,5kHz):
tonecall: 1,9kHz
DTMF: 1,7kHz

@25kHz bandwith (dev. should be 5kHz):
tonecall: 3,7kHz
DTMF: 3,4kHz

Note: Voice deviation is ok @12,5kHz & @25kHz bandwith
73, Peter DG3GSP

VK3KYY
Posts: 3203
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: 1750Hz Tone not exact? FM-Repeater problem

Post by VK3KYY » Mon Jul 20, 2020 11:52 am

Peter

Thanks...

Did you compare with the official firmware on the same radio, or are the correct values from some other radio or the ideal values ??

The reason I ask, is in case the problem is the values in the calibration may be too low.

But if the official firmware is correct, but this firmware is wrong.. Either the official firmware has a multiple or an offset value applied to the calibration value, or there is some other parameter which also needs to be changed in the AT1846S RF chip /

DG3GSP
Posts: 97
Joined: Sun Nov 17, 2019 9:30 am
Location: Southern Germany

Re: 1750Hz Tone not exact? FM-Repeater problem

Post by DG3GSP » Mon Jul 20, 2020 2:41 pm

Hi Roger,

2.5kHz / 5kHz deviation are ideal values..

A compare was today not possible - i had no feasibility in the lab to change the firmware and only little time..sorry

However, the deviation was sufficient to activate numerous analog repeater - i think the main problem was solved herewith.

But i try to made an deviation test with the factory firmware tomorrow.
73, Peter DG3GSP

VK3KYY
Posts: 3203
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: 1750Hz Tone not exact? FM-Repeater problem

Post by VK3KYY » Mon Jul 20, 2020 9:17 pm

DG3GSP wrote:
Mon Jul 20, 2020 2:41 pm
Hi Roger,

2.5kHz / 5kHz deviation are ideal values..

A compare was today not possible - i had no feasibility in the lab to change the firmware and only little time..sorry

However, the deviation was sufficient to activate numerous analog repeater - i think the main problem was solved herewith.

But i try to made an deviation test with the factory firmware tomorrow.
Thaanks

Post Reply