OpenGD77 BluedV Android Issue

EA1MU
Posts: 4
Joined: Sat Nov 16, 2019 9:49 am

Re: OpenGD77 BluedV Android Issue

Post by EA1MU » Mon Jan 06, 2020 10:39 am

Good morning, look at the programming cable, it can give you mistakes, it happens to me too, regards, 73s.

IK8JHL
Posts: 99
Joined: Tue Dec 10, 2019 11:19 am

Re: OpenGD77 BluedV Android Issue

Post by IK8JHL » Mon Jan 06, 2020 12:16 pm

EA1MU wrote:
Mon Jan 06, 2020 10:39 am
Good morning, look at the programming cable, it can give you mistakes, it happens to me too, regards, 73s.

With Bluedv of Windows work well. I must try to change the OTG cable, but then it works well on Android?Its only my issue?

EA1MU
Posts: 4
Joined: Sat Nov 16, 2019 9:49 am

Re: OpenGD77 BluedV Android Issue

Post by EA1MU » Tue Jan 07, 2020 9:41 am

Connect the gd77 to the phone with OTG cable, first press and hold the black side key when turning it on, this is important. change the channel to your access point, then, in TCPUART (transmission speed 115200), click on CONNECT, will the phone ask you with allow? click OK and then on the tcp server click SERVER, enter 2000 and START.
   press your start button (leaving TCPUART running in the background)
   start BLUEDV, configure, enable ser2net, enter ip 127.0.0.1 click send
   the radio should now say WAITING FOR TRACKING, click on the BLUEDV PHONE ICON and connect
   sometimes you may need to restart TCPUART
   If it doesn't work, verify that your phone is OTG compatible
   good luck

User avatar
m1dyp
Posts: 325
Joined: Sat Nov 16, 2019 8:03 am
Location: Hertfordshire, U.K.

Re: OpenGD77 BluedV Android Issue

Post by m1dyp » Tue Jan 07, 2020 11:20 am

Hi all :D

recent changes to the tcpuart android app have caused me issues with reliability with the gd77 as a hotspot on android (under windows its fine) so I looked at the video posted on youtube by Riku https://www.youtube.com/watch?v=2OSyDwcrSuc and its dated Sep 16, 2019.

based on the date, the version of tcpuart would have been TCPUART_v1.2

so, I uninstalled v1.2.2 and reinstalled v1.2

using the latest bluedv 1.0.121 app

it still took 2 or 3 attempts to get it running, however, once running, it appears to be stable, however, on my old samsung sm-j320fn (Samsung Galaxy J3 2016) its a bit ropy :mrgreen: , other, newer devices, work fine.

here's hoping this helps someone
20200107_113047-1.jpg
20200107_113047-1.jpg (88.12 KiB) Viewed 220 times
UPDATE v1.2.3 on a newer tablet works great first time :mrgreen:

I should also add that I am using the latest firmware 6 jan 2020
Attachments
TCPUART_v1.2_apkpure.com.zip
(166.98 KiB) Downloaded 17 times
73 de Ken :D

IK8JHL
Posts: 99
Joined: Tue Dec 10, 2019 11:19 am

Re: OpenGD77 BluedV Android Issue

Post by IK8JHL » Tue Jan 07, 2020 3:07 pm

Thanks ea1mu but as you can see from the video everything works, but in TX after a few seconds it stops transmitting, in RX it's fine.Thanks m1ydp also with TCPUART 1.2 I have the same problem, I tried to change OTG and cable, but I always have the same issue, I will have to change Phone :(

User avatar
KU4ZD
Posts: 149
Joined: Sat Nov 16, 2019 2:47 pm
Location: Council Bluffs, Iowa
Contact:

Re: OpenGD77 BluedV Android Issue

Post by KU4ZD » Tue Jan 07, 2020 8:13 pm

I did get the updated version 1.2.3 to run and got the TGIF network to set up and working
Mike KU4ZD

kt4lh
Posts: 67
Joined: Sun Jan 12, 2020 4:27 am

Re: OpenGD77 BluedV Android Issue

Post by kt4lh » Mon Jan 13, 2020 8:21 pm

IK8JHL wrote:
Tue Jan 07, 2020 3:07 pm
Thanks ea1mu but as you can see from the video everything works, but in TX after a few seconds it stops transmitting, in RX it's fine.Thanks m1ydp also with TCPUART 1.2 I have the same problem, I tried to change OTG and cable, but I always have the same issue, I will have to change Phone :(
You sure it's not RF causing issues? Maybe external antenna, or get cabling away from the antennas as much as possible, chokes, etc? Just a thought.

IK8JHL
Posts: 99
Joined: Tue Dec 10, 2019 11:19 am

Re: OpenGD77 BluedV Android Issue

Post by IK8JHL » Mon Jan 13, 2020 8:30 pm

I had tried with dummy load, but with my Huawei it always does. Now I have tested on a Samsung and it works

kt4lh
Posts: 67
Joined: Sun Jan 12, 2020 4:27 am

Re: OpenGD77 BluedV Android Issue

Post by kt4lh » Tue Jan 14, 2020 9:47 pm

IK8JHL wrote:
Mon Jan 13, 2020 8:30 pm
I had tried with dummy load, but with my Huawei it always does. Now I have tested on a Samsung and it works
I tried with my Nexus 7 2013 and I couldn't get BlueDV to do anything and every time I hit the multitasking/recents button and flipped back to TCPUART, the Server bit was stopped. I guess Android was killing it. :( Worked quite reliably on my Pixel 3 XL, however.

Post Reply