[Fixed] Display Frequency error in hotspot mode

Post Reply
User avatar
EA5SW
Posts: 52
Joined: Sat Nov 16, 2019 9:45 am
Location: Valencia, Spain
Contact:

[Fixed] Display Frequency error in hotspot mode

Post by EA5SW » Thu Dec 12, 2019 7:13 am

Appears in some frequencys with 00

Example:

438.012500 are displayed as 438.1250


The frequency are OK, but the displayed not..
Jose - EA5SW - Valencia

VK3KYY
Posts: 1969
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Display Frequency error in hotspot mode

Post by VK3KYY » Thu Dec 12, 2019 9:01 am

EA5SW wrote:
Thu Dec 12, 2019 7:13 am
Appears in some frequencys with 00

Example:

438.012500 are displayed as 438.1250


The frequency are OK, but the displayed not..
OK

Is the hotspot on 438.012500 or 438.1250

User avatar
EA5SW
Posts: 52
Joined: Sat Nov 16, 2019 9:45 am
Location: Valencia, Spain
Contact:

Re: Display Frequency error in hotspot mode

Post by EA5SW » Thu Dec 12, 2019 9:14 pm

438.012500
Jose - EA5SW - Valencia

IZ0MXY
Posts: 5
Joined: Sat Dec 14, 2019 7:53 am
Location: Rome Italy - loc.JN61GV

Re: Display Frequency error in hotspot mode

Post by IZ0MXY » Sun Dec 15, 2019 7:37 am

In hotspot mode the same thing happens to me too, with mmdvmhost, pi-star and blue.dv ...

if the frequency of 430.050.000 is set, 430.5000 is displayed
if set at 431.050.000, 431.5000 is displayed
if set at 430.150.000, 430.1500 is displayed correctly,

tested with OpenGD77_latest.sgl, firmwareversions 12 and 14 December.

73' iz0mxy

VK3KYY
Posts: 1969
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Display Frequency error in hotspot mode

Post by VK3KYY » Sun Dec 15, 2019 8:19 am

IZ0MXY wrote:
Sun Dec 15, 2019 7:37 am
In hotspot mode the same thing happens to me too, with mmdvmhost, pi-star and blue.dv ...

if the frequency of 430.050.000 is set, 430.5000 is displayed
if set at 431.050.000, 431.5000 is displayed
if set at 430.150.000, 430.1500 is displayed correctly,

tested with OpenGD77_latest.sgl, firmwareversions 12 and 14 December.

73' iz0mxy
Thanks

I'll will look at this now.

I think its probably caused by the changed we made a few weeks ago to increase the frequency resolution

VK3KYY
Posts: 1969
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Display Frequency error in hotspot mode

Post by VK3KYY » Sun Dec 15, 2019 8:52 am

I've attached a version with the frequency display problem fixed.

The fix will also be part of the next "Latest" version whenever its released
Attachments
OpenGD77_20191215195)_hotspot_freq_display_fix.sgl
(477.06 KiB) Downloaded 34 times

User avatar
m1dyp
Posts: 382
Joined: Sat Nov 16, 2019 8:03 am
Location: Hertfordshire, U.K.

Re: Display Frequency error in hotspot mode

Post by m1dyp » Sun Dec 15, 2019 10:23 am

thank you
73 de Ken :D

IZ0MXY
Posts: 5
Joined: Sat Dec 14, 2019 7:53 am
Location: Rome Italy - loc.JN61GV

Re: Display Frequency error in hotspot mode

Post by IZ0MXY » Sun Dec 15, 2019 12:07 pm

A quick report for the team ...

I tested with the new version,
OpenGD77_20191215195) _hotspot_freq_display_fix

Now the correct frequency is shown during reception
instead when transmitting the hotspot, the wrong frequency is still indicated.

73 ' iz0mxy Antonio

VK3KYY
Posts: 1969
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Display Frequency error in hotspot mode

Post by VK3KYY » Sun Dec 15, 2019 9:32 pm

Lol

Ah.

I only changed the Rx, I didn’t realise the Tx had the same problem

I will fix it

IZ0MXY
Posts: 5
Joined: Sat Dec 14, 2019 7:53 am
Location: Rome Italy - loc.JN61GV

Re: Display Frequency error in hotspot mode

Post by IZ0MXY » Tue Dec 17, 2019 7:38 pm

Hi Roger,

I just installed the OpenGD77_latest.sgl downloaded today and I confirm that
the problem of incorrect frequency indication has been solved

Thank you very much for your attention

73 'iz0mxy Antonio

Post Reply