GD77 Not Powering On - Fixed

Post Reply
shanetrain
Posts: 4
Joined: Sun Jun 28, 2020 1:52 am

GD77 Not Powering On - Fixed

Post by shanetrain » Wed Sep 02, 2020 7:34 am

Hi all.

Just thought i would share my issues with the GD77 not powering on.
Unit had something rattling around in it and radio would not power on.

After removing the main-board I found a small bit of solder floating around in the unit, this caused the issues.
Note - removing the GD77 main-board requires de-soldering the antenna connection, see attached picture.

I then discovered a little fuse on the board that had blown, (Littelfuse 3A FF Surface Mount Fuse, 32V ac/dc)
https://au.rs-online.com/web/p/non-rese ... s/5413619/

Replaced the fuse and the unit works again, hopefully this helps someone that has a non working unit.

De-solder the antenna connection image.
https://ibb.co/J37wbHB

Fuse location Image
https://ibb.co/GtStD2j
VK5URD

VK3KYY
Posts: 2996
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: GD77 Not Powering On - Fixed

Post by VK3KYY » Thu Sep 03, 2020 9:50 am

shanetrain wrote:
Wed Sep 02, 2020 7:34 am
Hi all.

Just thought i would share my issues with the GD77 not powering on.
Unit had something rattling around in it and radio would not power on.

After removing the main-board I found a small bit of solder floating around in the unit, this caused the issues.
Note - removing the GD77 main-board requires de-soldering the antenna connection, see attached picture.

I then discovered a little fuse on the board that had blown, (Littelfuse 3A FF Surface Mount Fuse, 32V ac/dc)
https://au.rs-online.com/web/p/non-rese ... s/5413619/

Replaced the fuse and the unit works again, hopefully this helps someone that has a non working unit.

De-solder the antenna connection image.
https://ibb.co/J37wbHB

Fuse location Image
https://ibb.co/GtStD2j
Very useful.

Thankyou

G4EML
Posts: 240
Joined: Sat Nov 16, 2019 10:01 am

Re: GD77 Not Powering On - Fixed

Post by G4EML » Thu Sep 03, 2020 11:05 am

I purchased a non working GD77 from EBay for a low bid.

That also had a blown fuse but in my case it was caused by a short circuit capacitor on the board. Took a little while to find but since replacing it the radio has been working fine.

Colin G4EML.

Post Reply