Addition power settings?

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Addition power settings?

Post by VK3KYY » Thu Jan 30, 2020 9:59 pm

I did some more tests and have slightly adjusted the parameters (scaling factors) for the 2,3 and 4W as well as the fixed offsets I use for the 250,500 and 750mW values.

One thing I have noticed is that the battery voltage makes a big difference to the output power.

My battery was at 100% and the battery screen displayed 8.3V.

I noticed if I transmitted on hight power, with the power meter connected, the power would start to drop after around 10 seconds, by a few hundred mW.

So I don't think we're ever going to be able to get completely accurate power outputs.


The other thing I tried was to completely turn off the PA, and I found that my Duplex Hotspot did not detect any signal from the radio, even though it was less than 1m away.

My other radios e.g. other GD-77's can detect the signal, but the hotspots are not very sensitive.

Currently power levels below 1W are calculated by subtracting a fixed value from the value required for 1W (from the calibration data)
However, I think that I should probably change this, and use a fraction of the value required for 1W.

But to get 250mW, the fraction would not be 1/4 (0.25) as the power curve is non linear.

I know people would like a 50mW setting, but I wonder whether the hotspots are sensitive enough even to receive a 50mW signal when you may be in another room and have multiple walls between the radio and the HS.
Attachments
opengd77_202001310839_power_calibration.sgl
(477.06 KiB) Downloaded 11 times

kt4lh
Posts: 79
Joined: Sun Jan 12, 2020 4:27 am

Re: Addition power settings?

Post by kt4lh » Thu Jan 30, 2020 11:55 pm

If you want to include a 50mW setting and get some feedback I imagine there are people that'd be willing to help. :) I can't measure mine, I have a junky meter that I'm not sure it's even accurate down below 5w honestly so I can't help out too much with calibration but can give you some feedback on 50mW hotspot usage.

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Addition power settings?

Post by VK3KYY » Fri Jan 31, 2020 12:00 am

kt4lh wrote:
Thu Jan 30, 2020 11:55 pm
If you want to include a 50mW setting and get some feedback I imagine there are people that'd be willing to help. :) I can't measure mine, I have a junky meter that I'm not sure it's even accurate down below 5w honestly so I can't help out too much with calibration but can give you some feedback on 50mW hotspot usage.
My power meter seems to not display anything below around 75mW or perhaps 60mW, So thats about as close as I could attempt to set the 50mW power setting.

I'm looking at something else at the moment, but I'll have a go at adding a 50mW power setting this evening (which will be tomorrow for anyone in the USA etc)

NA7Q
Posts: 106
Joined: Wed Jan 01, 2020 3:41 pm

Re: Addition power settings?

Post by NA7Q » Fri Jan 31, 2020 12:32 am

VK3KYY wrote:
Thu Jan 30, 2020 9:59 pm
I did some more tests and have slightly adjusted the parameters (scaling factors) for the 2,3 and 4W as well as the fixed offsets I use for the 250,500 and 750mW values.

One thing I have noticed is that the battery voltage makes a big difference to the output power.

My battery was at 100% and the battery screen displayed 8.3V.

I noticed if I transmitted on hight power, with the power meter connected, the power would start to drop after around 10 seconds, by a few hundred mW.

So I don't think we're ever going to be able to get completely accurate power outputs.


The other thing I tried was to completely turn off the PA, and I found that my Duplex Hotspot did not detect any signal from the radio, even though it was less than 1m away.

My other radios e.g. other GD-77's can detect the signal, but the hotspots are not very sensitive.

Currently power levels below 1W are calculated by subtracting a fixed value from the value required for 1W (from the calibration data)
However, I think that I should probably change this, and use a fraction of the value required for 1W.

But to get 250mW, the fraction would not be 1/4 (0.25) as the power curve is non linear.

I know people would like a 50mW setting, but I wonder whether the hotspots are sensitive enough even to receive a 50mW signal when you may be in another room and have multiple walls between the radio and the HS.
Hotspots may not be all that sensitive. But repeaters and nodes are. For those of us who "DX" on low power, the lower the better. Or those of us who live very close to repeaters or nodes. I have a hotspot radio, but I use the GD-77 on my hilltop repeater, and my node located at my QTH. Where I can use less than 250mW with ease. I like the idea of the lower power, and think I'll add that in either way on my builds.

Each year I work stations and repeaters up to 300 miles away using VHF/UHF with as little as 100mw on other capable radios.

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Addition power settings?

Post by VK3KYY » Fri Jan 31, 2020 12:49 am

Yep. Repeaters can be really sensitive.

I can just about access a repeater around 50kM from here on 250mW !

NA7Q
Posts: 106
Joined: Wed Jan 01, 2020 3:41 pm

Re: Addition power settings?

Post by NA7Q » Fri Jan 31, 2020 1:53 am

I went ahead and added the support for the extra power levels down to 50mW on my builds. I added 75mW and 100mW to it also. They are *rough* estimates. My meter doesn't do well below about 70-80mW, so it's a lot of guess work, but should be fairly close.

Download from here.
viewtopic.php?f=15&t=425

kt4lh
Posts: 79
Joined: Sun Jan 12, 2020 4:27 am

Re: Addition power settings?

Post by kt4lh » Fri Jan 31, 2020 2:27 am

Interesting, my hotspot doesn't hear anything on 50mW, even close. 75mW seems fine. Even across the house. Like 50mW isn't doing anything at all.

Messed about a bit more, 50mW if the HT is literally touching the hotspot is heard, signal seems good, S9+30 but anything a inch or two away, nothing. 75mW is sketchy if it'll work. 100mW seems okay.

NA7Q
Posts: 106
Joined: Wed Jan 01, 2020 3:41 pm

Re: Addition power settings?

Post by NA7Q » Fri Jan 31, 2020 2:47 am

kt4lh wrote:
Fri Jan 31, 2020 2:27 am
Interesting, my hotspot doesn't hear anything on 50mW, even close. 75mW seems fine. Even across the house. Like 50mW isn't doing anything at all.

Messed about a bit more, 50mW if the HT is literally touching the hotspot is heard, signal seems good, S9+30 but anything a inch or two away, nothing. 75mW is sketchy if it'll work. 100mW seems okay.
Hotspots are notoriously deaf.. To say the least. I was able to hit my repeater at 17 miles away with an RSSI of -103 at 50mW, and I'm not at all line of sight. And the signal increased accordingly as the power went up. So it's outputting power, but I wouldn't expect the hotspot to hear it well, or at all as you get much lower than 500mW.

kt4lh
Posts: 79
Joined: Sun Jan 12, 2020 4:27 am

Re: Addition power settings?

Post by kt4lh » Fri Jan 31, 2020 2:53 am

NA7Q wrote:
Fri Jan 31, 2020 2:47 am
Hotspots are notoriously deaf.. To say the least. I was able to hit my repeater at 17 miles away with an RSSI of -103 at 50mW, and I'm not at all line of sight. And the signal increased accordingly as the power went up. So it's outputting power, but I wouldn't expect the hotspot to hear it well, or at all as you get much lower than 500mW.
250mW has worked since I moved to OpenGD77, I'm never more than like 30 feet from the hotspot generally, so it's not exactly DX but it's just a Pi-W-Z sitting on the desk with the junky antenna that came with the MMDVM, seems fine. For all I know, maybe 50mW is outputting zero on my radio, I have no way to tell.

Also don't have any sane way to tell if 100mW uses less power than 250mW, but always happy to test and report what I see. What do you guys use to measure such power levels?

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Addition power settings?

Post by VK3KYY » Fri Jan 31, 2020 3:17 am

kt4lh wrote:
Fri Jan 31, 2020 2:53 am
250mW has worked since I moved to OpenGD77, I'm never more than like 30 feet from the hotspot generally, so it's not exactly DX but it's just a Pi-W-Z sitting on the desk with the junky antenna that came with the MMDVM, seems fine. For all I know, maybe 50mW is outputting zero on my radio, I have no way to tell.

Also don't have any sane way to tell if 100mW uses less power than 250mW, but always happy to test and report what I see. What do you guys use to measure such power levels?


The problem is most likely that its very hard to set the radio to output 50mW. Or even 75mW.

So the power setting on one radio to give 50mW could be a lot different for another radio to give 50mW

I've attached my version of 50mW, and also has 5W++ mode, and various other changes

It may or may no be giving 50mW on your radio
Attachments
opengd77_202001311412.sgl
(477.06 KiB) Downloaded 15 times

Post Reply