[Resolved] Development environment, toolchain and build instructions

Discussions related to the firmware code development
User avatar
F1RMB
Posts: 837
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: [Resolved] Development environment, toolchain and build instructions

Post by F1RMB » Tue Sep 08, 2020 5:57 am

Also

Code: Select all

bool oldVal=nonVolatileSettings.audioPromptMode;
is wrong, audioPromptMode is an uint8_t, not a boolean.


Cheers.
---
Daniel
73 de Daniel.

User avatar
F1RMB
Posts: 837
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: [Resolved] Development environment, toolchain and build instructions

Post by F1RMB » Tue Sep 08, 2020 5:59 am

Again ;-)

Reading the log, I see git is not found on your system. If you have it installed (under Windows as far as I can see), you need to add its path to the global PATH envvar.


Cheers.
---
Daniel
73 de Daniel.

User avatar
F1RMB
Posts: 837
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: [Resolved] Development environment, toolchain and build instructions

Post by F1RMB » Tue Sep 08, 2020 6:14 am

About the boot problem, I don't see anything wrong, the IDE is building the firmware for a GD77. I don't know which HT you own.
When you are flashing that transceiver, are you uploading the "firmware/Debug_GD-77/OpenGD77.sgl" ?
Also, did you tried to clean the build and rebuild it (menu "Project" -> "Clean...") ?


Cheers.
---
Daniel
73 de Daniel.

Post Reply