Release 3rd May

Post Reply
VK3KYY
Posts: 2417
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Release 3rd May

Post by VK3KYY » Sun May 03, 2020 10:21 am

Because of a major problem with the Tx Power level on the RD-5R, I have released a new version for all radios.

See

https://github.com/rogerclarkmelbourne/ ... /R20200503

The other major update is the inclusion of DCS support, thanks to KC7RBW, as well as some other GUI enhancements (by Daniel F1RMB), and also some bug fixes by me.

See the release change log on the Github page.


Note.

The power output on the RD-5R version is still far from correct, but it should no longer be overdriving the PA.

As things currently stand, I don't think there is any likelihood of the Tx power calibration being fixed on the RD-5R.

I simply don't have the time to take my RD-5R to pieces, and solder wires to the C6000 and AT1846S in order to reverse engineer the data being sent to these chips, in order to understand why the power output is so wrong.

And the last time I was in contact with Dzmitry EW1ADG, who ported the OpenGD77 to the RD-5R, he was in lockdown, and didn't have any access to anything like a logic analyser or a scope etc

I will contact Dzmitry again, and alert him to this major problem with the Tx power level, but I think it could be many months before he is able to investigate the problem.

User avatar
F1CXG
Posts: 164
Joined: Sat Nov 16, 2019 7:24 am
Location: GRENOBLE (France)

Re: Release 3rd May

Post by F1CXG » Sun May 03, 2020 10:42 am

Thanks Roger ( & Daniel) ;)
73 de Thierry ;)

User avatar
m1dyp
Posts: 402
Joined: Sat Nov 16, 2019 8:03 am
Location: Hertfordshire, U.K.

Re: Release 3rd May

Post by m1dyp » Sun May 03, 2020 11:09 am

thank you all
73 de Ken :D

trevormc626
Posts: 1
Joined: Sat Apr 11, 2020 7:38 pm

Re: Release 3rd May

Post by trevormc626 » Sun May 03, 2020 12:33 pm

THANKS

User avatar
F1CXG
Posts: 164
Joined: Sat Nov 16, 2019 7:24 am
Location: GRENOBLE (France)

Re: Release 3rd May

Post by F1CXG » Sun May 03, 2020 1:25 pm

Something weird with the latest version of this day on one of my 3 GD77s:
No melody on starting.
No keypad beeps.
No sound at the start and at the end of the broadcast
In FM by opening the squelch, there is normal sound.
In DMR parrot, the server responds but no sound, by calling, no one answers.
Back to the version of April 30, everything is OK, re switch to version May 3: same problems ....
The other two GD77s work fine with the May 3 release.
Here it is ;)
73 de Thierry ;)

User avatar
F1RMB
Posts: 681
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: Release 3rd May

Post by F1RMB » Sun May 03, 2020 1:37 pm

Hi Thierry,
F1CXG wrote:
Sun May 03, 2020 1:25 pm
Something weird with the latest version of this day on one of my 3 GD77s:
No melody on starting.
No keypad beeps.
No sound at the start and at the end of the broadcast
In FM by opening the squelch, there is normal sound.
In DMR parrot, the server responds but no sound, by calling, no one answers.
Back to the version of April 30, everything is OK, re switch to version May 3: same problems ....
The other two GD77s work fine with the May 3 release.
Here it is ;)
Sounds weird. Did you tried to reset the settings ?

Cheers.
---
Daniel
73 de Daniel.

User avatar
F1CXG
Posts: 164
Joined: Sat Nov 16, 2019 7:24 am
Location: GRENOBLE (France)

Re: Release 3rd May

Post by F1CXG » Sun May 03, 2020 1:49 pm

Hi Daniel, a reset setting and it's ok, strange that only one GD77 is affected.
73 de Thierry ;)

User avatar
F1CXG
Posts: 164
Joined: Sat Nov 16, 2019 7:24 am
Location: GRENOBLE (France)

Re: Release 3rd May

Post by F1CXG » Sun May 03, 2020 2:05 pm

I found again the problem , and resolved it.
If the volume of the keypad beeps is set lower than +3db, no sound.
I already had the problem few month ago and the next update removed it at the time.
73 de Thierry ;)

SO5AJG
Posts: 60
Joined: Sat Nov 16, 2019 3:44 pm

Re: Release 3rd May

Post by SO5AJG » Sun May 03, 2020 2:14 pm

I also confirm that in the RD-5R after switching on there is no characteristic melody, moreover, I cannot hear the correspondent talking, although it can be seen on the screen that he is in communication. Turning the radio on and off repeatedly will sound up, but not every time.

In GD-77 I ​​have the same problem with sound, only setting the sound level + 3dB solves this anomaly.
Janusz - SO5AJG - Warsaw

n1id
Posts: 14
Joined: Sat Nov 30, 2019 12:30 pm

Re: Release 3rd May

Post by n1id » Sun May 03, 2020 4:04 pm

I had the same audio problem on my 3 gd77s changed the setting to +3db and all worked then set it back down

Post Reply