Update 6th March Version 2

kt4lh
Posts: 139
Joined: Sun Jan 12, 2020 4:27 am

Re: Update 6th March Version 2

Post by kt4lh » Fri Mar 06, 2020 10:52 pm

VK3KYY wrote:
Fri Mar 06, 2020 10:44 pm
kt4lh wrote:
Fri Mar 06, 2020 10:37 pm
Is there a way to back up the calibration, or does that happen as part of the codeplug?
Its part of the CPS.

But make sure you download the latest CPS to match this firmware, otherwise uploading the firmware will do nothing as the old CPS uploads to the old calibration storage address in the Flash memory
Yep, went ahead and downloaded from the radio in the old CPS, saved, updated CPS and radio, seems okay except either I'm insane or I can NOT find my "Unlink" contact anywhere. It's still in the CPS as a Digital Contact, but I can't find it in the radio nor in any TG Lists I had before, nor can I re-add it to a TG List. Are Private contacts being filtered out? I think a non-private works too, but this seems like an odd limitation somewhere?

User avatar
KU4ZD
Posts: 159
Joined: Sat Nov 16, 2019 2:47 pm
Location: Council Bluffs, Iowa
Contact:

Re: Update 6th March Version 2

Post by KU4ZD » Sat Mar 07, 2020 12:02 am

I tried up update, I downloaded the updated CPS and this firmware. After updating the firmware I have a message on my screen that says '`Flash Mem Error" with the radio on or off and I can not load anything or get rid of the error message nor do anything at this point? any ideas?
VK3KYY wrote:
Fri Mar 06, 2020 10:55 am
Yet another update today !

https://github.com/rogerclarkmelbourne/ ... latest.sgl

Changes to this version are as follows.
  • The firmware makes a copy of the calibration table and saves it at address 0xF000 in Flash. This change was made so that the DM-1801 and GD-77 calibration table can be at the same address and only one CPS is then needed for both radios. (Note the DM-1801 version also has to copy the calibration to 0xF000 but its original location is different from the GD-77 calibration table
  • Speed of access to the Flash memory has been improved by the removal of some redundant code, which kept checking if the Flash was busy
  • Improve boot speed, by removal of the 500mS delay at the start of the code, which no longer seemed to be needed. (You probably won't notice this change)
  • Updated translations for some languages, for the new Sound Options menu
  • Scan option in the VFO quick menu can now be activated by pressing the Orange button again (like on the Channel screen)
  • Location of the Scan option has been moved to make it easier to get to in the VFO quick menu (and on the DM-1801 the VFO quick menu Scan option is in the same location in the menu as on the Channel screen, because the DM-1801 does not need the option to change VFO, as it has a separate button "A/B" for this.
  • Screen backlight PWM frequency has been increased from 2.4kHz to 10kHz, because on the DM-1801 a 2.4kHz tone could be heard through the speaker when the backlight was on. (I don't recall hearing this on the GD-77, but it may cause a slight improvement on the GD-77 even if the sound was at a sub-audible level)

Note.

Because of the change to keep the calibration table for all radios in the same location, I've updated the CPS to handle this

https://github.com/rogerclarkmelbourne/ ... taller.exe
Mike KU4ZD

VK3KYY
Posts: 2433
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 6th March Version 2

Post by VK3KYY » Sat Mar 07, 2020 12:31 am

Load yesterdays firmware.

https://github.com/rogerclarkmelbourne/ ... latest.sgl

It uses the old calibration table.

BTW. I presume you're using a GD-77

User avatar
KU4ZD
Posts: 159
Joined: Sat Nov 16, 2019 2:47 pm
Location: Council Bluffs, Iowa
Contact:

Re: Update 6th March Version 2

Post by KU4ZD » Sat Mar 07, 2020 12:35 am

I am using the GD-77 and I will download yesterdays firmware but
at this point I a stuck, I can not do anything, I can not load firmware or get out of the error message

VK3KYY wrote:
Sat Mar 07, 2020 12:31 am
Load yesterdays firmware.

https://github.com/rogerclarkmelbourne/ ... latest.sgl

It uses the old calibration table.

BTW. I presume you're using a GD-77
Mike KU4ZD

kt4lh
Posts: 139
Joined: Sun Jan 12, 2020 4:27 am

Re: Update 6th March Version 2

Post by kt4lh » Sat Mar 07, 2020 12:40 am

KU4ZD wrote:
Sat Mar 07, 2020 12:35 am
I am using the GD-77 and I will download yesterdays firmware but
at this point I a stuck, I can not do anything, I can not load firmware or get out of the error message
You can't turn it on with the side buttons pressed and reflash? That is unexpected. Maybe turn off the power, remove battery, plug in battery, then buttons + power?

User avatar
KU4ZD
Posts: 159
Joined: Sat Nov 16, 2019 2:47 pm
Location: Council Bluffs, Iowa
Contact:

Re: Update 6th March Version 2

Post by KU4ZD » Sat Mar 07, 2020 12:53 am

Got it, I had to pull the battery a number of times before I could get the error message to go away and get it to reboot and allow me to reflash but finally got it to work, thank you

So now I am on the new cps and the last firmware version, should I back up my configurations again or I am ok with what I have backed up at this point?

I have never seen that error message before, and it was with power on and off on the GD-77 and had everything disabled


kt4lh wrote:
Sat Mar 07, 2020 12:40 am
KU4ZD wrote:
Sat Mar 07, 2020 12:35 am
I am using the GD-77 and I will download yesterdays firmware but
at this point I a stuck, I can not do anything, I can not load firmware or get out of the error message
You can't turn it on with the side buttons pressed and reflash? That is unexpected. Maybe turn off the power, remove battery, plug in battery, then buttons + power?
Mike KU4ZD

VK3KYY
Posts: 2433
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 6th March Version 2

Post by VK3KYY » Sat Mar 07, 2020 1:13 am

KU4ZD wrote:
Sat Mar 07, 2020 12:53 am
Got it, I had to pull the battery a number of times before I could get the error message to go away and get it to reboot and allow me to reflash but finally got it to work, thank you

So now I am on the new cps and the last firmware version, should I back up my configurations again or I am ok with what I have backed up at this point?

I have never seen that error message before, and it was with power on and off on the GD-77 and had everything disabled


kt4lh wrote:
Sat Mar 07, 2020 12:40 am
KU4ZD wrote:
Sat Mar 07, 2020 12:35 am
I am using the GD-77 and I will download yesterdays firmware but
at this point I a stuck, I can not do anything, I can not load firmware or get out of the error message
You can't turn it on with the side buttons pressed and reflash? That is unexpected. Maybe turn off the power, remove battery, plug in battery, then buttons + power?
Mick, thats really wierd. Its saying that the calibration data could not be copied to the new address.

So if you want to change the calibration, you'll need to use the Older CPS.

Everything else will work OK, but at the moment, you won't be able to use the newer versions of firmware until this problem is fixed in your radio.

I'll need to send you some diagnostic software to attempt to figure out why your radio could not copy the calibration to its new location..
But I don't have time to do that today.

User avatar
KU4ZD
Posts: 159
Joined: Sat Nov 16, 2019 2:47 pm
Location: Council Bluffs, Iowa
Contact:

Re: Update 6th March Version 2

Post by KU4ZD » Sat Mar 07, 2020 1:41 am

Sounds good, when ever you have time. No hurry.
VK3KYY wrote:
Sat Mar 07, 2020 1:13 am
KU4ZD wrote:
Sat Mar 07, 2020 12:53 am
Got it, I had to pull the battery a number of times before I could get the error message to go away and get it to reboot and allow me to reflash but finally got it to work, thank you

So now I am on the new cps and the last firmware version, should I back up my configurations again or I am ok with what I have backed up at this point?

I have never seen that error message before, and it was with power on and off on the GD-77 and had everything disabled


kt4lh wrote:
Sat Mar 07, 2020 12:40 am


You can't turn it on with the side buttons pressed and reflash? That is unexpected. Maybe turn off the power, remove battery, plug in battery, then buttons + power?
Mick, thats really wierd. Its saying that the calibration data could not be copied to the new address.

So if you want to change the calibration, you'll need to use the Older CPS.

Everything else will work OK, but at the moment, you won't be able to use the newer versions of firmware until this problem is fixed in your radio.

I'll need to send you some diagnostic software to attempt to figure out why your radio could not copy the calibration to its new location..
But I don't have time to do that today.
Mike KU4ZD

VK3KYY
Posts: 2433
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 6th March Version 2

Post by VK3KYY » Sat Mar 07, 2020 2:14 am

Mike

I'll email you directly with a custom SGL file, once I've worked out a way to write some debug messages via USB.

We already have a system to do this, but not one that would work when the radio is booting up, which is when the problem occurs

User avatar
kd2lh
Posts: 291
Joined: Mon Dec 02, 2019 2:44 pm

Re: Update 6th March Version 2

Post by kd2lh » Sat Mar 07, 2020 2:25 am

The new 3/6/2020 OpenGD77 CPS file is only 7,6mb in size. All the earlier ones were well over 9mb.

Is this the result of better compiler performance, or is something possibly missing?

Post Reply