Update 16th Jan

VK3KYY
Posts: 1656
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Update 16th Jan

Post by VK3KYY » Thu Jan 16, 2020 6:46 am

I've decided to release another update with hopefully a few minor improvements


https://github.com/rogerclarkmelbourne/ ... latest.sgl

This version now has the 1 frame DMR buffering, which from yesterday's feedback seemed to be the value used by TYT in their radios and which seemed no worse than a 2 frame buffer.

It also includes some fixes by Alex to the Private Call handling, including a new text translation for the Options screen text for this setting.

I've also made 2 other changes.

I've tried to increase the DMR audio level by changing the Line Out gain from 2db to the maximum of 6dB, which I think has made the audio a little louder.

I've also made an optimisation in the code, so that when the DMR audio is decoded by the AMBE decoder, it decodes directly into the output buffer, rather than into a temporary buffer which then has to be copied into the output buffer. This will slightly reduce the load on the CPU.

This version also includes the fix from Daniel for the DTMF FM Tx, which became broken with some of the previous changes to key handling.

User avatar
m1dyp
Posts: 334
Joined: Sat Nov 16, 2019 8:03 am
Location: Hertfordshire, U.K.

Re: Update 16th Jan

Post by m1dyp » Thu Jan 16, 2020 7:15 am

wow thank you. welcome back dtmf :mrgreen:
audio is improved
menus great
73 de Ken :D

VK3KYY
Posts: 1656
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 16th Jan

Post by VK3KYY » Thu Jan 16, 2020 7:19 am

m1dyp wrote:
Thu Jan 16, 2020 7:15 am
wow thank you. welcome back dtmf :mrgreen:
audio is improved
menus great
You're welcome

User avatar
F1CXG
Posts: 128
Joined: Sat Nov 16, 2019 7:24 am
Location: GRENOBLE (France)

Re: Update 16th Jan

Post by F1CXG » Thu Jan 16, 2020 8:04 am

Weirdness!
On one of my 3 GD77s, I no longer have sound with the latest version.
If I go back to another version like the "OpenGD77_20200161328_lineout_gain_6db.sgl" or an older one, the sound works correctly.
Systematically with the latest version: no sound. :o
(the other 2 GD77s work normally with the latest version.) :?

Edit : The sound works again with a "Beep" setting at + 3dB :o
Last edited by F1CXG on Thu Jan 16, 2020 8:11 am, edited 1 time in total.
73 de Thierry ;)

OK2HAD
Posts: 4
Joined: Wed Jan 08, 2020 1:10 pm
Location: Uherský Brod (Czech Republic)

Re: Update 16th Jan

Post by OK2HAD » Thu Jan 16, 2020 8:10 am

Hi,
  after the firmware has been installed on 16 January 2020, the start tone is not heard when the station is switched on.
The keypad tone does not come out of the speaker.
In DMR mode, no sounds come from the speaker.
FM sound works.
Excuse my pronunciation in English.
73 de František

User avatar
F1CXG
Posts: 128
Joined: Sat Nov 16, 2019 7:24 am
Location: GRENOBLE (France)

Re: Update 16th Jan

Post by F1CXG » Thu Jan 16, 2020 8:12 am

try this: set the Beep Volume à +3db ;)
73 de Thierry ;)

OK2HAD
Posts: 4
Joined: Wed Jan 08, 2020 1:10 pm
Location: Uherský Brod (Czech Republic)

Re: Update 16th Jan

Post by OK2HAD » Thu Jan 16, 2020 8:23 am

Thank you, i confirm The sound works again with a "Beep" setting at + 3dB u works well u 0db.
73 de František

VK3KYY
Posts: 1656
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 16th Jan

Post by VK3KYY » Thu Jan 16, 2020 8:52 am

F1CXG wrote:
Thu Jan 16, 2020 8:04 am
On one of my 3 GD77s, I no longer have sound with the latest version.
Can you try the version which just has the DMR level set to 6db

https://www.opengd77.com/viewtopic.php? ... 85c2887e71

Also

The changes to the AMBE audio decode are different to the beep audio system.

So it would be interesting to know if beeps work but DMR audio does not

VK3KYY
Posts: 1656
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 16th Jan

Post by VK3KYY » Thu Jan 16, 2020 10:00 am

F1CXG wrote:
Thu Jan 16, 2020 8:04 am
Edit : The sound works again with a "Beep" setting at + 3dB :o
Very strange.

What value did you have the beep volume, so that there was no audio at all?

The beep volume and beep is handled totally differently from the DMR audio level

User avatar
Ik0nwg
Posts: 66
Joined: Sat Nov 16, 2019 7:23 am
Location: JN61VG

Re: Update 16th Jan

Post by Ik0nwg » Thu Jan 16, 2020 10:57 am

With this version I have noticed significant improvements in decoding the DMR especially when the signal is very low in movement and is lost momentarily, in this unfavorable situation where the signal is lost and resumed the radio behaves very well. In previous versions, when the signal was picked up by the radio, there were malfunctions of a few moments. The slightly higher audio volume also helps in listening especially on the move. Thanks guys you are very good ....
Sal

Post Reply