CPS Update

VK3KYY
Posts: 2996
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: CPS Update

Post by VK3KYY » Thu Jul 16, 2020 7:53 am

CPS has been updated.

See

https://github.com/rogerclarkmelbourne/ ... 2020.07.16

This update is to help visually impaired operators, as it has keyboard shortcuts to Add and Delete, Channels and Contacts.

Note. There was also an update on 13th July, where unsupported features, like Scan Lists and Emergency systems etc, have been completely removed (hidden), in the CPS.

So its worth updating to get that enhancement as well

VK3KYY
Posts: 2996
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: CPS Update

Post by VK3KYY » Thu Jul 23, 2020 10:03 am

CPS has been updated to fix a bug when importing Channels from a CSV file, which resulted in duplicate contacts being created, and also duplicate TG's being added to the TG Lists

https://github.com/rogerclarkmelbourne/ ... 2020.07.23

User avatar
m1dyp
Posts: 481
Joined: Sat Nov 16, 2019 8:03 am
Location: Hertfordshire, U.K.
Contact:

Re: CPS Update

Post by m1dyp » Thu Jul 23, 2020 2:54 pm

thank you
73 de Ken :D

F6GVE
Posts: 74
Joined: Sat Nov 16, 2019 8:52 am

Re: CPS Update

Post by F6GVE » Fri Jul 24, 2020 8:09 pm

Very nice. Thank you again and again

nr0d
Posts: 14
Joined: Wed Jul 22, 2020 7:18 pm

Re: CPS Update

Post by nr0d » Sun Jul 26, 2020 10:19 pm

Thank you!

So I installed yesterday, and I still use a Windows 7 VM on my Linux machine, just so I don't have to deal with the mess that is Windows 10. Anyway, I don't know if this is the place to mention it, but my VM only had .NET runtime 4.4 installed, which caused the CPS to immediately crash with the traditional completely-unhelpful crash error of "CLR20r3" and searching online was quite unhelpful.

Anyway, I installed .NET 4.8 and things worked. I don't feel like I saw that mentioned in the user guide anywhere, does it bear mentioning or was my VM just so woefully out of date that I'm an outlier?

73, Tim

kt4lh
Posts: 151
Joined: Sun Jan 12, 2020 4:27 am

Re: CPS Update

Post by kt4lh » Wed Jul 29, 2020 7:18 pm

nr0d wrote:
Sun Jul 26, 2020 10:19 pm
Thank you!

So I installed yesterday, and I still use a Windows 7 VM on my Linux machine, just so I don't have to deal with the mess that is Windows 10. Anyway, I don't know if this is the place to mention it, but my VM only had .NET runtime 4.4 installed, which caused the CPS to immediately crash with the traditional completely-unhelpful crash error of "CLR20r3" and searching online was quite unhelpful.

Anyway, I installed .NET 4.8 and things worked. I don't feel like I saw that mentioned in the user guide anywhere, does it bear mentioning or was my VM just so woefully out of date that I'm an outlier?

73, Tim
Must be, same situation here, and I don't use that VM for ANYTHING except like 3 radios that only have Windows software and everything just-worked for me. I actually don't see .4.4 anywhere, but looks like your version was from at least 2012.

nr0d
Posts: 14
Joined: Wed Jul 22, 2020 7:18 pm

Re: CPS Update

Post by nr0d » Wed Jul 29, 2020 8:45 pm

Fair enough, thanks. I've had that VM for a loooong time, because I think it's using the license from my Dell Latitude e6510 that I got in 2013 and immediately loaded Ubuntu on. Only thing I use it for is downloading books to Adobe Digital Editions, running Uniden SW to manage my scanner, and CPS, but I think this is the first one that was written in .NET. So, since it's not a "real machine" I assume people on real machines have already been through all of this.

Anyway, it works and it works great now! But error messages like that are the reason I really don't miss running Windows other than this VM since 2006.

User avatar
WY7JT
Posts: 3
Joined: Thu Apr 09, 2020 4:49 pm

Re: CPS Update

Post by WY7JT » Thu Jul 30, 2020 5:44 pm

I've noticed the CPS Firmware loader is showing old dates for the stable and development versions. Mine shows June dates but the development version I just loaded has Jul 30th as the date.

User avatar
F1RMB
Posts: 837
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: CPS Update

Post by F1RMB » Thu Jul 30, 2020 5:50 pm

Hi,
WY7JT wrote:
Thu Jul 30, 2020 5:44 pm
I've noticed the CPS Firmware loader is showing old dates for the stable and development versions. Mine shows June dates but the development version I just loaded has Jul 30th as the date.
The version date for the development version is never changed, it's set on its creation and used as a rolling version.


Cheers.
---
Daniel
73 de Daniel.

VK3KYY
Posts: 2996
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: CPS Update

Post by VK3KYY » Fri Jul 31, 2020 11:17 pm

CPS has been updated to fix a problem where the icons were missing from the navigation buttons on the TG List screen

https://github.com/rogerclarkmelbourne/ ... 2020.08.01


Note.
They were deleted by the development environment, Visual Studio, because it often gets confused because the source code files were not originally created in Visual Studio, as they were reverse engineered from the official CPS exe.

Post Reply