Update 12th Feb

VK3KYY
Posts: 1586
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Update 12th Feb

Post by VK3KYY » Tue Feb 11, 2020 11:54 pm

I've released a new 'latest' version

https://github.com/rogerclarkmelbourne/ ... latest.sgl

This includes the new TalkGroup filtering, and also fixes the bug where the wrong text was being shown for "Contact list" in the Contact menu.

I've also modified the way the translation texts are handed, changing them from fixed length arrays to variable length pointers to character buffers.
This should slightly reduce the amount of program space used for the translation texts, as most of the texts are no where near as long as the fixed array size of 24 bytes. As far as I can tell the UI and translations are still working OK.


The TG filter is enabled by pressing the Orange button to select the context sensitive / quick menu, then selecting the "Filter:" option, and pressing the right arrow key to enable TG as well as TS filtering.

Then TG filtering is enabled, the mode text of "DMR" is shown in inverse video.


BTW.
Re: Filtering on all TG's in the TG list.

This would be possible but is not in this release.
I'd also like to add Contact list filtering, to only open the Rx when someone in my Contacts is calling, and this may be in a future release as well.

User avatar
4I1RAC
Posts: 141
Joined: Thu Nov 28, 2019 5:25 am
Location: Philippines
Contact:

Re: Update 12th Feb

Post by 4I1RAC » Tue Feb 11, 2020 11:58 pm

Thanks for the update, Roger. I'll add this in the documentation to do wiki.
Angelo, 4I1RAC / N2RAC
Brandmeister Philippines support team
Talkgroups
- 51518 crosslinked to DX1ARM 431.600 MHz Fusion repeater, Metro Manila
- 98977 Opengd77
- 515 Philippines

https://n2rac.com

VK3KYY
Posts: 1586
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 12th Feb

Post by VK3KYY » Wed Feb 12, 2020 12:54 am

Hi Angelo

I was planning to update the User Guide, but I didnt have time to do it yet.

User avatar
m1dyp
Posts: 323
Joined: Sat Nov 16, 2019 8:03 am
Location: Hertfordshire, U.K.

Re: Update 12th Feb

Post by m1dyp » Wed Feb 12, 2020 1:48 am

thank you
73 de Ken :D

User avatar
4I1RAC
Posts: 141
Joined: Thu Nov 28, 2019 5:25 am
Location: Philippines
Contact:

Re: Update 12th Feb

Post by 4I1RAC » Wed Feb 12, 2020 2:14 am

VK3KYY wrote:
Wed Feb 12, 2020 12:54 am
Hi Angelo

I was planning to update the User Guide, but I didnt have time to do it yet.
Yeah, there have been a lot of new stuff lately. And I think the guide may need to be reworked for better organization. At any rate, I have noted incremental updates here: https://github.com/jangelor/OpenGD77/wi ... ation-ToDo
Angelo, 4I1RAC / N2RAC
Brandmeister Philippines support team
Talkgroups
- 51518 crosslinked to DX1ARM 431.600 MHz Fusion repeater, Metro Manila
- 98977 Opengd77
- 515 Philippines

https://n2rac.com

VK3KYY
Posts: 1586
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 12th Feb

Post by VK3KYY » Wed Feb 12, 2020 2:18 am

4I1RAC wrote:
Wed Feb 12, 2020 2:14 am
VK3KYY wrote:
Wed Feb 12, 2020 12:54 am
Hi Angelo

I was planning to update the User Guide, but I didnt have time to do it yet.
Yeah, there have been a lot of new stuff lately. And I think the guide may need to be reworked for better organization. At any rate, I have noted incremental updates here: https://github.com/jangelor/OpenGD77/wi ... ation-ToDo
I just did some minor updates to the User Guide to include the TG filtering.

I have noticed however that its difficult linking from the index to the same functionality in both the Channel and the VFO Quick menu.

I don't know enough about MarkDown to know how to author the links correctly.

User avatar
kd2lh
Posts: 168
Joined: Mon Dec 02, 2019 2:44 pm

Locking up Re: Update 12th Feb

Post by kd2lh » Fri Feb 14, 2020 1:17 am

The Feb 12th version v0.1.0 is locking up on both my Pi4B and PiZeroW.

I'm returning to the prior firmware for testing.

This looks like the old buffer overrun problem, with the dashboard on PiStar frozen on TX

Both Raspberry Pis are generating quite a bit of heat during the failure (53.9 C on the Zero).

Marc

VK3KYY
Posts: 1586
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 12th Feb

Post by VK3KYY » Fri Feb 14, 2020 2:41 am

kd2lh wrote:
Fri Feb 14, 2020 1:17 am
The Feb 12th version v0.1.0 is locking up on both my Pi4B and PiZeroW.

I'm returning to the prior firmware for testing.

This looks like the old buffer overrun problem, with the dashboard on PiStar frozen on TX

Both Raspberry Pis are generating quite a bit of heat during the failure (53.9 C on the Zero).

Marc
Can you look in the "Firmware info" version code (not the hotspot version), for the version that works and the version that doesn't work.

Its the numbers and letters in the brackets at the bottom of that screen, and post both codes.

Then we can look at the changes between those two code numbers and try to track down if anything should have affected hotspot mode.

User avatar
kd2lh
Posts: 168
Joined: Mon Dec 02, 2019 2:44 pm

Re: Update 12th Feb

Post by kd2lh » Fri Feb 14, 2020 3:14 am

Hi Roger,

The last version that works is:

[ a0f4440 ]

The version that fails is:

[ 5e2bc47 ]

VK3KYY
Posts: 1586
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Update 12th Feb

Post by VK3KYY » Fri Feb 14, 2020 3:58 am

kd2lh wrote:
Fri Feb 14, 2020 3:14 am
Hi Roger,

The last version that works is:

[ a0f4440 ]

The version that fails is:

[ 5e2bc47 ]
OK.

Thanks.

I'll see what has changed

Post Reply