Code plug read/write error

prattmd
Posts: 12
Joined: Mon Dec 23, 2019 9:57 pm

Re: Code plug read/write error

Post by prattmd » Mon Dec 30, 2019 1:54 am

ee the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.IO.IOException: The I/O operation has been aborted because of either a thread exit or an application request.

at System.IO.Ports.InternalResources.WinIOError(Int32 errorCode, String str)
at System.IO.Ports.InternalResources.WinIOError()
at System.IO.Ports.SerialStream.get_BytesToRead()
at System.IO.Ports.SerialPort.get_BytesToRead()
at DMR.OpenGD77Form.ReadFlashOrEEPROMOrROMOrScreengrab(OpenGD77CommsTransferData dataObj) in d:\projects\rogerclark\DMR\radioddity_gd-77_cps\Extras\OpenGD77\OpenGD77Form.cs:line 272
at DMR.OpenGD77Form.worker_DoWork(Object sender, DoWorkEventArgs e) in d:\projects\rogerclark\DMR\radioddity_gd-77_cps\Extras\OpenGD77\OpenGD77Form.cs:line 954
at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Mon Dec 30, 2019 2:48 am

What antivirus software are you using?
BTW.

Line 272 is while (commPort.BytesToRead == 0)

From this code

Code: Select all

				commPort.Write(sendbuffer, 0, 8);
				while (commPort.BytesToRead == 0)
				{
					Thread.Sleep(0);
				}
				commPort.Read(readbuffer, 0, 64);

prattmd
Posts: 12
Joined: Mon Dec 23, 2019 9:57 pm

Re: Code plug read/write error

Post by prattmd » Mon Dec 30, 2019 3:07 am

Webroot secure anywhere
But I have tried a PC with none

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Mon Dec 30, 2019 3:17 am

prattmd wrote:
Mon Dec 30, 2019 3:07 am
Webroot secure anywhere
But I have tried a PC with none
OK.

What CPU etc does the PC use

prattmd
Posts: 12
Joined: Mon Dec 23, 2019 9:57 pm

Re: Code plug read/write error

Post by prattmd » Mon Dec 30, 2019 4:30 am

I have tried an intel i5 and i7 16 GB ram

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Mon Dec 30, 2019 4:47 am

I just re-tested on 2 other machines, all with clean W10 installs and unfortunately I can't replicate the bug on any of them :-(

One is a brand new Core i7, and the other is a 5 year old Macbook, Core i3 which is now running W10.

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Mon Dec 30, 2019 4:54 am

BTW.

Did you post your codeplug. I guess there is a chance this is related to a specific codeplug (but I can't see how)

prattmd
Posts: 12
Joined: Mon Dec 23, 2019 9:57 pm

Re: Code plug read/write error

Post by prattmd » Mon Dec 30, 2019 5:09 am

This was just trying to read it

prattmd
Posts: 12
Joined: Mon Dec 23, 2019 9:57 pm

Re: Code plug read/write error

Post by prattmd » Mon Dec 30, 2019 5:10 am

Could it be the chipset of the radio ?
I have one of the very first gd 77 that came out ?

prattmd
Posts: 12
Joined: Mon Dec 23, 2019 9:57 pm

Re: Code plug read/write error

Post by prattmd » Mon Dec 30, 2019 5:37 am

I just ordered a new programming cable. Only thing else I can try. Will let you know.

Post Reply