Code plug read/write error

User avatar
YT5HOK
Posts: 124
Joined: Sat Nov 16, 2019 11:36 am
Location: Belgrade, KN04FR

Re: Code plug read/write error

Post by YT5HOK » Sun Dec 15, 2019 8:16 am

VK3KYY wrote:
Sat Dec 14, 2019 11:53 pm
...
Strangely the OpenGD77 version, seems to have IO issues even though its the same source code, whereas the Community CPS doesnt seem to have that issue, which is very strange.
Administrator rights? More then a few of amateur radio programs I use need admin rights to run properly.
Marko

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Sun Dec 15, 2019 8:53 am

Most programs need admin rights to install but the CPS should not need it to run.

User avatar
YT5HOK
Posts: 124
Joined: Sat Nov 16, 2019 11:36 am
Location: Belgrade, KN04FR

Re: Code plug read/write error

Post by YT5HOK » Sun Dec 15, 2019 9:02 am

VK3KYY wrote:
Sun Dec 15, 2019 8:53 am
Most programs need admin rights to install but the CPS should not need it to run.
...but to communicate with the device...? Few days ago I programmed GD-55+ for my friend and the official CPS needed admin rights.
Marko

sq1fyi
Posts: 3
Joined: Tue Dec 17, 2019 1:38 pm

Re: Code plug read/write error

Post by sq1fyi » Tue Dec 17, 2019 1:57 pm

Hi.
I have the same problem.
Radio during downloading codeplug reset and show up errors:
"Operation I/O break..."
or
"Port is closed"
or
"Device connected to the computer not working"

After acknowledge got message "Read Codeplug Complete" but download only my callsign and DMR ID.
:(

mprattmd
Posts: 1
Joined: Tue Dec 24, 2019 12:58 am

Re: Code plug read/write error

Post by mprattmd » Tue Dec 24, 2019 3:59 am

I have a fresh flash of the stable branch of OpenGD77

I have tried both the Community CPS and the OpenGD77 CPS. I see a com port assigned to the usb cable, but neither version of the CPS will allow me to write or read a codeplug.

I get the I/O operation error

I was able to use the community CPS before opengd77 firmware.

I have tried multiple USB ports as well as 2 different computers

I am running Win 10

I have run in admin mode

Any other suggestions?

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Tue Dec 24, 2019 5:55 am

Is the IO error half way through writing the codeplug ?

prattmd
Posts: 12
Joined: Mon Dec 23, 2019 9:57 pm

Re: Code plug read/write error

Post by prattmd » Sun Dec 29, 2019 9:37 pm

About 1 second after I try to write
I know it can connect because it can read the eprom

prattmd
Posts: 12
Joined: Mon Dec 23, 2019 9:57 pm

Re: Code plug read/write error

Post by prattmd » Sun Dec 29, 2019 10:32 pm

I have now tried both the Tier 1 and Tier 2 firmwares, No issues writing the firmwares,

I have now tried a third computer running Win 10 still get the I/O error

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Sun Dec 29, 2019 10:46 pm

Writing the firmware uses USB HID, the codeplug uses a COM port, hence the firmware loading may work even when the codeplug write doesn't.

VK3KYY
Posts: 1961
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Sun Dec 29, 2019 10:48 pm

Download this zip file and unzip into a folder and then try running the GD77CPS.exe

https://drive.google.com/open?id=1QFqqu ... VSBaIfvwk8


It will still fail to upload, but it should provide a lot more debugging information, and possibly show which line in the source code has the problem

Post Reply