Code plug read/write error

deon

Code plug read/write error

Post by deon » Tue Dec 03, 2019 11:12 am

Hi everyone,

I've been unsuccessful in getting the Community CPS (Build 20191125) to read and write code plugs to my radio. Every time I try to read or write to the GD77 (running firmware built 20191121) the application throws an error which I have attached as screen capture. The firmware uploader works and I am also able to backup the EEPROM and Flash without errors.

I am running Windows 10 Education 1903 and have tried restarting as well as different USB ports but to no avail.

Anyone have any ideas?

Thanks in advance,
Deon
Attachments
error.PNG
error.PNG (16.57 KiB) Viewed 2114 times

VK3KYY
Posts: 3006
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Tue Dec 03, 2019 9:15 pm

Thats odd

Can you restore the EEPROM ?

deon

Re: Code plug read/write error

Post by deon » Tue Dec 03, 2019 11:24 pm

Yes, I am able to restore the EEPROM.

I just tried to read the code plug with my laptop also running Windows 10 Education and it throws the same error as well.

VK3KYY
Posts: 3006
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Tue Dec 03, 2019 11:28 pm

Thats really strange

Can you try another machine

VK2CNN
Posts: 4
Joined: Tue Dec 03, 2019 11:16 pm

Re: Code plug read/write error

Post by VK2CNN » Wed Dec 04, 2019 12:10 am

Hi,
I did have the exact same problem as Deon.
I was able to do the OpenGD77 firmware updates with community custom cps but could not read or write codeplugs as I was getting the same error message as Deon. I used to read or write using factory cps and did the firmware updates using community custom cps. While trying to find the solution, I went into Roger's website and found 2 links to Community cps and one was slightly modified/changed. I uninstalled the one I installed and installed the other one, my problem disappeared. I can now read or write codeplugs without any issues. By the way I run Windows 10 on my PC. Maybe Roger can lead you to the links.

Thank you.
Geoff VK2CNN

deon

Re: Code plug read/write error

Post by deon » Wed Dec 04, 2019 12:29 am

I tried the CPS in my Windows 7 virtual machine and it gave a different error about the device not being found or something along those lines. I think this is happening because the radio reboots during code plug read/write and VMware does not connect the radio back to the VM automatically. Either way the radio restarts exactly the same as it did when it threw the error in my original post.

I will have a look around for alternative versions of the Community CPS and see if it solves the problem like it did for VK2CNN.

VK3KYY
Posts: 3006
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Wed Dec 04, 2019 12:49 am

The official firmware uses a USB HID interface protocol which is basically a modified version of the keyboard / mouse interface.

Then OpenGD77 uses a normal COM device so that it can also interface with PiStar etc as a Hotspot

There are technical reasons why the code can't operate as both or even be switch-able between HID and COM port, including lack of space in the 512k ROM to support multiple USB protcols and also because the NXP SDK examples on which the USB interface is based, are not written in a way that can handle switching USB protocols - without re-writing a lot of the standard USB code.

Lots of other people are using Windows 10, so its not specifically a W10 problem.

I agree this is a problem for some people, but also that it can be made to work.

Vk3TEN
Posts: 5
Joined: Fri Dec 06, 2019 4:33 am

Re: Code plug read/write error

Post by Vk3TEN » Sun Dec 08, 2019 12:00 pm

Had the same issue. The software in the New CPS thread fixed it. I.e. https://drive.google.com/uc?id=1Z5ry0Nu ... t=download

ad4uu
Posts: 9
Joined: Thu Dec 12, 2019 11:24 pm

Re: Code plug read/write error

Post by ad4uu » Sat Dec 14, 2019 11:28 pm

I have the same issue with the CPS. When trying to download the CPS from the published link I get:
Sorry, this file is infected with a virus

Only the owner is allowed to download infected files

Any suggestions.

Thanks
Dave/AD4UU

VK3KYY
Posts: 3006
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Code plug read/write error

Post by VK3KYY » Sat Dec 14, 2019 11:53 pm

You can use both the Community CPS which works for both the official and OpenGD77 firmware, and also the OpenGD77 version

Strangely the OpenGD77 version, seems to have IO issues even though its the same source code, whereas the Community CPS doesnt seem to have that issue, which is very strange.

Post Reply