White noise after changing slot

ea3ihi
Posts: 55
Joined: Fri Jan 10, 2020 9:28 pm
Location: Barcelona, Spain

White noise after changing slot

Post by ea3ihi » Fri Jan 24, 2020 6:57 pm

If you are listening to DMR in a slot and there is audio signal, if you press the star key to change slot and in the new slot there is no audio, a white noise can be heard. Should audio be turned off when changing slot? (maybe by calling terminate_digital()?)
EA3IHI - David

VK3KYY
Posts: 1611
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: White noise after changing slot

Post by VK3KYY » Fri Jan 24, 2020 9:39 pm

I never hear this in normal operation

But if I change some optimisation settings it always has very loud white noise on all DMR signals.
Hence this sounds like another optimisation issue, but only in the version you have built yourself

ea3ihi
Posts: 55
Joined: Fri Jan 10, 2020 9:28 pm
Location: Barcelona, Spain

Re: White noise after changing slot

Post by ea3ihi » Sat Jan 25, 2020 9:39 am

I can confirm the same happens with your latest build from the 22nd of January
EA3IHI - David

User avatar
EA5SW
Posts: 51
Joined: Sat Nov 16, 2019 9:45 am
Location: Valencia, Spain
Contact:

Re: White noise after changing slot

Post by EA5SW » Sat Jan 25, 2020 11:24 pm

The sound noise are low.. but I confirm this also in my own compilation.

Tested in duplex hotspot
Attachments
OpenGD77-EA5SW-10Hz_50mW_250120.sgl
(477.06 KiB) Downloaded 8 times
Jose - EA5SW - Valencia

VK3KYY
Posts: 1611
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: White noise after changing slot

Post by VK3KYY » Sat Jan 25, 2020 11:38 pm

I tested this on several radios and I don't hear it at all.

So it seems that it only happens on some radios.

ilmiser
Posts: 5
Joined: Wed Jan 29, 2020 11:48 am

Re: White noise after changing slot

Post by ilmiser » Sun Feb 16, 2020 9:58 am

Same problem here with latest (16/02/2020)... It's not only when changing slot.
You can reproduce this problem even pressing green key and going back with red if you are on TS2 and see traffic on TS1.
If the speaker "opens" (e.g. to beep if you press a key) and on the other TS there's some traffic then the speaker "remains open" emitting white noise until the traffic on all TS ceases (green light off).
After that, all starts working normally.
my 2c: maybe you only have to tell to "close" the speaker after the beep.

73
IU2JXM
Last edited by ilmiser on Sun Feb 16, 2020 10:10 am, edited 1 time in total.

VK3KYY
Posts: 1611
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: White noise after changing slot

Post by VK3KYY » Sun Feb 16, 2020 10:08 am

Does this occur in the latest version ?

ilmiser
Posts: 5
Joined: Wed Jan 29, 2020 11:48 am

Re: White noise after changing slot

Post by ilmiser » Sun Feb 16, 2020 10:35 am

VK3KYY wrote:
Sun Feb 16, 2020 10:08 am
Does this occur in the latest version ?
Yes, tested it just before posting.. updated with the firmware published on GitHub 4-5 hours ago

VK3KYY
Posts: 1611
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: White noise after changing slot

Post by VK3KYY » Sun Feb 16, 2020 11:22 am

Ok

I will investigate

ilmiser
Posts: 5
Joined: Wed Jan 29, 2020 11:48 am

Re: White noise after changing slot

Post by ilmiser » Sun Feb 16, 2020 12:09 pm

Many thanks Roger.
The job you all are doing with OpenGD77 is great.

Post Reply