[Charger fault] Fully charged battery shows 94%

Post Reply
G0NHF
Posts: 61
Joined: Sun Jan 19, 2020 10:28 am

[Charger fault] Fully charged battery shows 94%

Post by G0NHF » Mon Jan 20, 2020 9:08 pm

I notice that every time I take my radio off the charger fully charged, the battery indicator only shows 94%
I’ve tried two batteries and the same happens with both. I don’t really care much about this but just thought it was strange as the videos on YouTube that Roger has made, clearly show the battery on his radio at 100%.

Just thought I would mention it just incase I have some issue going on?

Regards Tony G0NHF

VK3KYY
Posts: 2972
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Fully charged battery shows 94%

Post by VK3KYY » Mon Jan 20, 2020 9:42 pm

Your charger is not fully charging the battery.

If you measure your battery voltage it will not be 8.3V

kt4lh
Posts: 156
Joined: Sun Jan 12, 2020 4:27 am

Re: Fully charged battery shows 94%

Post by kt4lh » Tue Jan 21, 2020 3:08 am

I'm using a TP5100 module in my GD77 base with a 12V input from my radiio PSU to charge my GD77 (and MD380), and it charges about twice as fast, less heat, and less RFI. I've also noticed my radio is almost always at 94%, maybe for giggles I'll try my other base which I did not modify and see what it does. I've never worried about it too much honestly.

G0NHF
Posts: 61
Joined: Sun Jan 19, 2020 10:28 am

Re: Fully charged battery shows 94%

Post by G0NHF » Tue Jan 21, 2020 10:08 am

Thanks Roger,

I’m not bothered about it, but just thought I would mention the fact it does always shows 94% and no more. I don’t normally pay much attention to battery levels that much. I have another charger here so next time I charge, I will try that one and also take note of the indicated battery voltage as soon as it stops charging.

Great work Roger, you have created a new radio with this firmware. Brilliant stuff.... !

Regards Tony G0NHF

VK3KYY
Posts: 2972
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Fully charged battery shows 94%

Post by VK3KYY » Tue Jan 21, 2020 10:14 am

Hi Tony,

We have already adjusted the 100% voltage down from 8.4V to (I think ) 8.2V

A good Lipo charger would change the battery pack to somewhere around 8.4V and definitely above 8.2V, but the change controller in the GD-77 charger is just a couple of OpAmps, and doesn't work that well.

I know a lot of people remove the charge controller PCB from inside the charger and replace it with a $2 module, which changes faster and give a better full charge voltage.

User avatar
F1RMB
Posts: 826
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: Fully charged battery shows 94%

Post by F1RMB » Tue Jan 21, 2020 10:32 am

Hi,

I have 3 batteries, on the same charger 2 displays 100%, one 94% since day one.

Cheers.
73 de Daniel.

User avatar
F1CXG
Posts: 168
Joined: Sat Nov 16, 2019 7:24 am
Location: GRENOBLE (France)

Re: Fully charged battery shows 94%

Post by F1CXG » Tue Jan 21, 2020 11:11 am

Hi,

I also have 3 batteries, on the same charger, 2 at 100%, one 94% but I worry no more than that :)
I have ordered some TP5100 circuits to have a faster an accurate charge ....
73 de Thierry ;)

User avatar
EA3BIL
Posts: 70
Joined: Sat Nov 16, 2019 12:38 pm

Re: Fully charged battery shows 94%

Post by EA3BIL » Mon Feb 10, 2020 10:24 pm

I have 2 batteries (one from GD77 and one from GD77S).
Both do show values about 93% "fully charged" so,
I've ordered a few units of TP5100 circuit for abt USD1.7 each one (including transport from CN to ES), for having chargers "repaired".

Questions for those who already have one of those devices:
Jumper must be soldered for 8.4v, isn't it ?
TP5100_SetUp.png
TP5100_SetUp.png (346.94 KiB) Viewed 723 times


Thanks for helping !!

BTW,
They notify about delays on shippings due to virus crisis in there.
Note:
Now you can find me on YouTube.
Productions are NOT in English... Yet.


73'Rafa.
EA3BIL.

VK3KYY
Posts: 2972
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: Fully charged battery shows 94%

Post by VK3KYY » Mon Feb 10, 2020 10:40 pm

I noticed the TP5100 don't actually charge to 8.4V even with the 2 pads shorted.

Mine only charges to 8.2V.

I guess we could set the 100% reading to an even lower voltage e.g. 8.0V but I'm sure people would also get confused with this, because the display would show 100% before the maximum charge voltage.

User avatar
EA3BIL
Posts: 70
Joined: Sat Nov 16, 2019 12:38 pm

Re: Fully charged battery shows 94%

Post by EA3BIL » Mon Feb 10, 2020 11:25 pm

I see...
Anyway, TP5100 will do better than current one in there.
Also a unit will be used on a demaged charger from a colleague...
As soon as I'll have them installed I'll tell you.


Setting 100% at 8.1 does make sense ??
It's a reference, so I think it's not too critical. Is it ?
Note:
Now you can find me on YouTube.
Productions are NOT in English... Yet.


73'Rafa.
EA3BIL.

Post Reply