[Fix in next release] CWID Breaks Operations

Post Reply
User avatar
kd2lh
Posts: 171
Joined: Mon Dec 02, 2019 2:44 pm

[Fix in next release] CWID Breaks Operations

Post by kd2lh » Sun Jan 12, 2020 8:56 pm

If I turn on the CW ID feature (In MMDVMHOST Expert settings), the hotspot will stop operating properly.

This error is seen in the live log:
E: 2020-01-12 20:51:20.847 Unable to read the firmware version after six attempts

and eventually the DMR connections to the VOIP network (DMR Enabled and Network Status) (Brandmeister) turn RED.

When I stop CW ID Mode and reboot, all operates properly.

VK3KYY
Posts: 1611
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: OpenGD77 Hotspot Mode CWID Breaks Operations

Post by VK3KYY » Sun Jan 12, 2020 10:18 pm


User avatar
kd2lh
Posts: 171
Joined: Mon Dec 02, 2019 2:44 pm

Re: OpenGD77 Hotspot Mode CWID Breaks Operations

Post by kd2lh » Sun Jan 12, 2020 11:47 pm

Thanks Roger. Let me know how I can help.
Marc

VK3KYY
Posts: 1611
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: OpenGD77 Hotspot Mode CWID Breaks Operations

Post by VK3KYY » Mon Jan 13, 2020 12:34 am

kd2lh wrote:
Sun Jan 12, 2020 11:47 pm
Thanks Roger. Let me know how I can help.
Marc
I had a quick look at the code, but I can't see anything obviously wrong

User avatar
F1RMB
Posts: 404
Joined: Sat Nov 16, 2019 5:42 am
Location: Grenoble, France
Contact:

Re: OpenGD77 Hotspot Mode CWID Breaks Operations

Post by F1RMB » Mon Jan 13, 2020 4:17 am

Hi Marc,
kd2lh wrote:
Sun Jan 12, 2020 8:56 pm
If I turn on the CW ID feature (In MMDVMHOST Expert settings), the hotspot will stop operating properly.

This error is seen in the live log:
E: 2020-01-12 20:51:20.847 Unable to read the firmware version after six attempts

and eventually the DMR connections to the VOIP network (DMR Enabled and Network Status) (Brandmeister) turn RED.

When I stop CW ID Mode and reboot, all operates properly.
Okay, I raised a PR to fix this, and another one about new private call handling.


Cheers.
73 de Daniel.

VK3KYY
Posts: 1611
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: OpenGD77 Hotspot Mode CWID Breaks Operations

Post by VK3KYY » Mon Jan 13, 2020 4:27 am

Thanks

I was about to test the CW ID to see why it failed, but I'll now pull the PR and test it to confirm if the change fixes it.

VK3KYY
Posts: 1611
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: OpenGD77 Hotspot Mode CWID Breaks Operations

Post by VK3KYY » Mon Jan 13, 2020 6:05 am

Its been running for several hours on TG91 without any problems, so I think its fixed.

However I won't be releasing an update for a few days as there are other non-Hotspot related bugs which need to be fixed before I can do that.

User avatar
kd2lh
Posts: 171
Joined: Mon Dec 02, 2019 2:44 pm

Re: [Fix in next release] CWID Breaks Operations

Post by kd2lh » Sat Jan 18, 2020 2:12 am

Now testing with the 20200116 version firmware.

In Expert / edit_mmdvmhost / CWID is set to "1" and TIME is set to "5" for testing.

The hotspot does not lockup as in the prior bug, but no code is being transmitted at the 5 minute (or any) interval.

I would expect to hear my configured call in Morse audio on an analog HT tuned to the hotspot frequency.

Have the complete fixes been committed by this firmware, or is this still being worked on?

Thanks again, Marc

VK3KYY
Posts: 1611
Joined: Sat Nov 16, 2019 3:25 am
Location: Melbourne, Australia
Contact:

Re: [Fix in next release] CWID Breaks Operations

Post by VK3KYY » Sat Jan 18, 2020 2:30 am

Transmission of CW ID is not currently supported and the command is currently ignored.

Post Reply